Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 10, 2026 - 14:00 UTC
Scheduled
We are deploying a minor update to our stage environment and do not anticipate any downtime.
This release is expected to go to production on Monday 15th June.
ISD-508: Improve object-selection behaviour in tables. Resolving a reported issue with object API calls in multi-line tables where calls were not correctly firing on additional rows. Note that new lines will not make requests until users interact with them in some way.
If you are an organisation administrator and have complex forms requesting objects in table-rows, we recommend testing on stage before we go to production on Monday. Please let us know of any queries or concerns through the usual channels.
Posted Jun 10, 2026 - 13:59 UTC
This scheduled maintenance affected: ERPPORTAL (ERP Portals STAGE system).